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1. Document Details 
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1.1 Summary 
This is the release for the Brother FCM Thumbnail Viewer User Guide release V1.0.22 user guide. 

1.2 Supersedes 
None. 

1.3 Version History 
Version Date Details 
1.0.02 23 April 2015 Authors & Contributors at this version 

Ian Wadsworth. 
 
First issue.  

   

1.4 Copyright 
This document, test files, executables and related files are copyright of Ian Wadsworth (except where 
indicated), and must not be distributed to any un-authorised testers without the consent of Ian Wadsworth. 
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2. Release and System 
Requirements Information 



Brother FCM Thumbnail Viewer User Guide V1.0.22 
 

Page 8 

2.1 Disclaimer 
There is no connection whatsoever between Brother, and the Intellectual Property owner of this application. In 
other words, they don’t own or control it, nor have they approved or disproved of the application. 

2.2 Software Use 
• The software is supplied as is. It may contain defects, and may not be fit for purpose. 
• The author cannot be held responsible for any loss of data caused by using the application. 
• It has been checked for viruses, but it is up to the user to check that their system have the latest anti-

virus software installed and enabled. 

2.3 Copyright Acknowledgements 
All registered trademarks are recognised, and are not used to exclusively promote the application. 

2.4 End User Licence 
Please read the document ‘eula.rtf’. 
 

• The software is licensed, and is not owned. 
• No selling or renting of the executable file 
• Internationally copyright protected. 
• It may not be re-sold, rented, etc. 
• Please don't distribute the executable file, link it to this website 

2.5 Release Notes 
New releases are at http://www.ideas-r-us-software.uk/Downloads.aspx 
 
A help forum is at http://www.ideas-r-us.co.uk/forum/ 

2.5.1 Changes Made in Version 1.0.22 
2.5.1.1 New Features 
Added support for reading FCM files created for the SDX Roll Feeder. Note: The thumbnails appear to be 
cropped. 

2.5.2 Changes Made in Version 1.0.21 
2.5.2.1 Issues Fixed 
Files with errors caused an unexpected exception, and didn't display the rest of the thumbnails. Fixed. 

2.5.3 Changes Made in Version 1.0.20 
2.5.3.1 New Features 

• Added support for reading thumbnails from FCD and FC1 files 
• The thumbnails can be printed 

http://www.ideas-r-us.co.uk/Downloads.aspx
http://www.ideas-r-us.co.uk/forum/
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2.5.3.2 Issues Fixed 
• When the filename label is longer than the width of the thumbnail, it is not displayed. Ellipses '...' will 

be added to the filename label, and the full name can be viewed when the mouse pointer is hovered over 
the label. Fixed. 

• The filenames were not sorted when more than one was added/viewed. Fixed. 

2.5.3.3 Improved 
Moved the filename label closer to the thumbnail image. 

2.6 Reporting Issues (Bugs) 
Issues can be reported by going to the forum at http://www.ideas-r-us.co.uk/forum/. 

2.7 System Requirements 
• Requires Windows XP, Windows Vista, Windows 7 or Windows 8.x. 
• At least 3MB of hard disk space 
• The application uses about 22MB of DRAM. 
• Requires the Microsoft .NET Framework 3.5 Service Pack 1 (Requires at least Service Pack 2 Win XP), 

if not already installed. The installer will detect if the framework is installed or not. 
o If you have Internet access it can be downloaded from http://www.microsoft.com/en-

gb/download/details.aspx?id=25150 (about 235MB) 
o If no Internet access, it may be on the operating systems install disk. 

 
The supplied files are: - 
  

BrotherFCMThumbnailViewer.exe 
BrotherFCMThumbnailViewerUserGuide.pdf 
eula.rtf 
unins000.dat 
unins000.exe 

 

http://www.ideas-r-us.co.uk/forum/
http://www.microsoft.com/en-gb/download/details.aspx?id=25150
http://www.microsoft.com/en-gb/download/details.aspx?id=25150
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3. The Application 
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3.1 Background Information 
The Brother ScanNCut machine uses Brother’s proprietary FCM file format to either cut or draw images. 
 
The drawings can either be created within the machine itself, or by using an online web based application called 
Canvas. 

3.2 Main Features/Description 
• View the thumbnail (preview) images that are saved with the FCM files. 
• These are the 'preview' images that are seen on the coloured LCD (Liquid Crystal Display) screen of 

Brother Scan and Cut machines. 
• Cutter Controller has the ability to export the thumbnail preview images in colour. 

3.3 Running the Application 
There are three ways that the Brother FCM Thumbnail Viewer application can be started: - 
 

1. Clicking on the desktop program icon (if created). 
2. From the start menu -> Programs -> Brother FCM Thumbnail Viewer -> Brother FCM Thumbnail 

Viewer (if created). 
3. By clicking on the Brother FCM Thumbnail Viewer in the BrotherFCMThumbnailViewer (where the 

application was installed). 
 
The main form will appear (see Picture 1 Screen Shot of the ). 
 
When the application is first run, there can be quite a long start up delay. After that, the start up will be much 
quicker. This will always be the case when the system is restarted. 
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4. Main Form Overview  
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This is the main form after starting. 
 
Picture 1 Screen Shot of the Brother FCM Thumbnail Viewer 

 

4.1 Drag and Drop a File 
Drag and Drop a file from a file viewer such as Explorer onto the form’s ‘canvas’. 
 

Select an FCM file, then click and hold the mouse button. When the mouse is moved it will change to a  
symbol (no drop). 

Drag the file onto the Brother FCM Thumbnail Viewer ‘canvas’; the cursor will change to a  symbol (drop 
and copy). Release the mouse button and the FCM file should appear. 
 
If the form’s ‘canvas’ is hidden, drag the file to the Brother FCM Thumbnail Viewer task bar button. The form 
will now be visible. 
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5. Menu 
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• File Menu 
• Help Menu 

5.1 File Menu 
 

 
 

• Open Files 
• Page Setup 
• Print Preview 
• Print 
• Exit 

5.1.1 Open Files 
Menu -> File -> Open Files 
Ctrl + O 
Toolbar, see 6.2 Open Files Button 
 
The supported files are Brother FCM, FC1 and FCD. 
 
Clicking the button will show a standard Windows ‘Open File’ dialogue box. Select any FCM/FC1/FCD file to 
load it. 
 
Select a single or multiple files to view. The number of FCM/FC1/FCD files read is displayed on the bottom 
status bar. 
 
There are two mat sizes for the Brother ScanNCut machines, 12 inches x 12 inches and 12 inches x 24 inches. 
The 12 x 24 thumbnails are smaller in width than the 12 x 12 thumbnails. 
 
The coloured thumbnails have been created in the Cutter Controller application available from http://ideas-r-us-
software.uk/Downloads.aspx#CutterController. 
 
A bad or damaged FCM file is indicated by an image of a red circle with a line through it. 
 

http://ideas-r-us-software.uk/Downloads.aspx#CutterController
http://ideas-r-us-software.uk/Downloads.aspx#CutterController
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Picture 2 Colour Preview Thumbnails Created in Cutter Controller 

 
 

5.1.1.1 Error Messages 
See the section Appendix in Error and Warning Messages Pop Up Boxes. 

5.1.2 Page Setup 
Menu -> File -> Page Setup 
 
This is the standard Windows Page Set-up form that sets the paper size, paper orientation, paper/printer margins 
and printer. 
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Picture 3 Print Page Set-up Form 

 

5.1.3 Print Preview 
Menu -> File -> Print Preview 
Toolbar, see 6.3 Print Preview 
 
This is greyed out when there is no pattern files to print. 
 
This is the standard Windows Print Preview form that shows what the patterns should look like when printed 
(see Picture 5 Print Preview Set-up Form (No Borders)). 
 
The ‘Page Options’ form will first appear (see Picture 4 Page Options Form). 
 
Enter the Page Header text, and check the ‘Show Border’ box to add a border around the thumbnail image. 
Click the OK button to show the Print Preview Form dialogue. 
 
Picture 4 Page Options Form 
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Picture 5 Print Preview Set-up Form (No Borders) 

 

5.1.4 Print 
Menu -> File -> Print Preview 
Ctrl + P 
Toolbar, see 6.4 Print 
 
This is greyed out when there is no pattern files to print. 
 
This is the standard Windows Print form where a printer can be selected (see Picture 7 Print Form). Make sure 
you’ve set it up correctly before clicking the ‘Print’ button. 
 
The ‘Page Options’ form will first appear (see Picture 6 Page Options Form). 
 
Enter the Page Header text, and check the ‘Show Border’ box to add a border around the thumbnail image. 
Click the OK button to show the Print Preview Form dialogue. 
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Picture 6 Page Options Form 

 
 
Picture 7 Print Form 

 

5.1.5 Exit 
Menu -> File -> Exit 
Alt + F4 
 
Exit or closes the application. 

5.2 Help Menu 
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• User Guide 
• Installation Folder 
• Check for Updates 
• About 

5.2.1 User Guide 
Menu -> Help -> User Guide 
 
You are reading it! This will open the PDF User Guide. A PDF reader must be installed to view the User Guide; 
otherwise an error message will be displayed. 
 
It is located in the Installation Folder, or in the Documents sub-folder (see 5.2.2 Installation Folder). 

5.2.2 Installation Folder 
Menu -> Help -> Installation Folder 
 
This will open the folder where ‘Brother FCM Thumbnail Viewer’ is installed. If it cannot, an error message 
will be displayed. 
 
Picture 8 Installation Folder 

 
 

5.2.3 Check for Updates 
Menu -> Help -> Check for Updates 
Ctrl + U 
 
Checks if there is an update to the current application. 
 
The latest release/update is also available from the Ideas R Us Software website (www.ideas-r-us-software.uk), 
from the Downloads web page. 
 
If the version is up to date, the message box in Picture 9 The Current Version is up to Date will be displayed. 
 
If there is an update available, the message box in Picture 10 There is a New Version Available will be 
displayed. 
 

http://www.ideas-r-us.co.uk/
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If there is a problem with the network connection or the update server, the message box in Picture 11 Network 
Connection Problem or Picture 12 Update Server Problem will be displayed. 
 
Note: There may be a delay before a pop-up message box, or an error message appears. 
 
Picture 9 The Current Version is up to Date 

 
 
Picture 10 There is a New Version Available 

 
 
Picture 11 Network Connection Problem 

 
 
Picture 12 Update Server Problem 

 
 

5.2.3.1 Download the New Version 
To download the new version, click the ‘Yes’ button in Picture 10 There is a New Version Available, the ‘Save 
As’ dialogue box will appear (see Picture 13 Select the Location to Save the Set up File). Clicking the ‘No’ 
button will cancel the download. 
 
Select the folder where the download file is to be saved (the file name can be renamed if required), then click 
the ‘Save’ button. After the file has finished downloading, a message will be displayed. Click the ‘OK’ button. 
 
Note: There is a short delay while the file is downloading. 



Brother FCM Thumbnail Viewer User Guide V1.0.22 
 

Page 22 

 
Picture 13 Select the Location to Save the Set up File 

 
 
Picture 14 The File has downloaded 

 

5.2.3.2 Installing the Update 
To install the update, the Brother FCM Thumbnail Viewer application must be closed down. 
 
An installation guide is available if help if needed with the install. See the Downloads web page from the Ideas 
R Us website (www.ideas-r-us-software.uk). 

5.2.3.3 Other Error Messages 
These are system errors. 
 

• The version information on the server is incorrect. 
• The version infomation file on the server is missing. 
• The download link on the server is missing. 
• The setup file on the server is missing. 

 
Note: Under certain conditions if the server is down or there is no network connection, these can also be 
displayed. 

http://www.ideas-r-us.co.uk/
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5.2.4 About 
Menu -> Help -> About 
F1 
 
Shows the ‘Brother FCM Thumbnail Viewer’, which is just version information, and where to report issues 
with the application. 
 
Picture 15 The ‘About’ Form for a Beta/Pre Release Version 
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6. Tool Bars 



Brother FCM Thumbnail Viewer User Guide V1.0.22 
 

Page 25 

 
 

6.1 Overview 
 

• Open Files Button 

6.2 Open Files Button 
 

 
 
See section 5.1.1 Open Files 

6.3 Print Preview 
 

 
 
See section 5.1.3 Print Preview 

6.4 Print 
 

 
 
See section 5.1.4 Print 
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7. Status Bar 
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7.1 Status Bar 
 
The status bar displays the number of thumbnails or the FCM files displayed. 
 
Picture 16 Status Bar 
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8. Appendix 
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8.1 Un-Installing 
The Brother FCM Thumbnail Viewer application can be un-installed from the Start Menu (see Picture 17 Un-
installing from the Start Menu). 
 
If there isn’t a Brother FCM Thumbnail Viewer Start Menu folder, the program can be un-installed from the 
Windows ‘Add/Remove Programs’ control panel. 
 
It can also be un-installed from double clicking on the unins000.exe in the Brother FCM Thumbnail Viewer 
installed folder. This is usually in the ‘C:\Program Files\IdeasRUsSoftware\BrotherFCMThumbnailViewer\’ 
folder. 
 
Picture 17 Un-installing from the Start Menu 

 
 
A confirmation pop-up message box will be displayed, click ‘Yes’ to install, and ‘No’ to cancel uninstall. 
 
Picture 18 Confirm Uninstall 

 
 
The Brother FCM Thumbnail Viewer application has been successfully removed. 
 
Picture 19 Successfully Uninstalled 

 
 

8.2 Keyboard Shortcuts 
Open Files   Ctrl + O 
Print    Ctrl + P 
Exit Program   Alt + F4 
Check for Updates  Ctrl + U 
About    F1 
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8.3 Error and Warning Messages Pop Up Boxes 
8.3.1 Un-handled Exception 
This is a system error, and not a user error. 
 
Picture 20 Example of an Un-handled Exception Error 

 

8.4 Previous Release Notes 
8.4.1 Changes Made in Version 1.0.10 
8.4.1.1 New Features 

• Coloured thumbnails produced by the Cutter Controller application can now be viewed 
• Added a menu item for User Guide in the Help menu 
• Added a menu item for the Installation Folder in the Help menu 
• Added a Check for Updates feature to the Help menu 
• Added a ‘Product Brand’ icon to the .exe file and to the main form 

8.4.1.2 Issues Fixed 
• The thumbnail bitmap reader wasn’t correctly reading the bitmap file. Fixed. 
• Removed the Black/White Greyscale option, since there was an issue with the bitmap reader. Fixed. 

8.4.1.3 Improved 
• The thumbnail load times have been improved. 
• The default install Program Group is now Ideas R Us Software\Brother FCM Thumbnail Viewer 

8.4.1.4 Updated 
Changed most of the URL's from ‘ideas-r-us.co.uk’ to ‘ideas-r-us-software.uk’. 

8.4.2 Changes Made in Version 1.0.03 
8.4.2.1 Issues Fixed 
The file names in the top row of the thumbnails were missing. Fixed. 
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8.4.3 Changes Made in Version 1.0.02 
8.4.3.1 New Features 
Added tool bar buttons for opening the FCM files and changing the thumbnails to be displayed as Black/White 
or Grey. 

8.4.3.2 Issues Fixed 
An un-handled exception error when selecting some FCM files. Fixed. 

8.4.4 Changes Made in Beta/Pre-Release Version 1.0.01 
8.4.4.1 Issues Fixed 
Some thumbnails were not displayed. Fixed. 
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