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1. Document Details 
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1.1 Summary 
This is the release for the Silhouette Studio Library Converter Free release V1.1.15. 

1.2 Supersedes 
None. 

1.3 Version History 
Version Date Details 
0.00 31 December 2014 Authors & Contributors at this version 

Ian Wadsworth. 
 
First issue.  

   

1.4 Copyright 
This document, test files, executables and related files are copyright of Ian Wadsworth (except where 
indicated), and must not be distributed to any un-authorised testers without the consent of Ian Wadsworth. 
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2. Release and System 
Requirements Information 
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2.1.1 Disclaimer 
There is no association between the Intellectual Property owner of this application and Silhouette America. This 
is NOT Silhouette America approved. In other words, they don’t own or control it. 

2.1.2 Copyright of the Extracted Files 
This creates a copy of the Silhouette Studio library files/images. This does not change the copyright or licence 
terms of any of the extracted files. These still belong to the author/owner of the original files/images, which will 
also apply to the extracted files/images. 

2.2 Software Use 
• The software is supplied as is. It may contain defects, and may not be fit for purpose. 
• The author cannot be held responsible for any loss of data caused by using the application. 
• It has been checked for viruses, but it is up to the user to check that their system have the latest anti-

virus software installed and enabled. 

2.3 Copyright Acknowledgements 
All registered trademarks are recognised, and are not used to exclusively promote the application. 

2.4 End User Licence 
Please read the document ‘eula.rtf’. 
 

• The software is licensed, and is not owned. 
• No selling or renting of the executable file 
• Internationally copyright protected. 
• It may not be re-sold, rented, etc. 
• Please don't distribute the executable file, link it to this website 

2.5 Release Notes 
The latest release/update is also available from the Ideas R Us Software website (http://www.ideas-r-us-
software.uk/), from the Downloads web page. 
 
A help forum is at http://www.ideas-r-us.co.uk/forum/ 
 

2.5.1 Changes Made in Version 1.1.15 
2.5.1.1 New Features 

• Cloud library entry extraction has now been fully implemented. 
• A menu item in the help menu to the location of the Silhouette Studio Library files. 
• The file extension of the library entry name has been added in the Library Entries Details group box. 
• The progress bar is updated when the Cloud Library Entries are being read in. 
• New category descriptions for 'Printable Pattern' and 'eBook' category types. 

2.5.1.2 Issues Fixed 
• All the files in the folders of the destination folder were being searched to see if the folder was empty, 

and was taking too long. Fixed. 

http://www.ideas-r-us-software.uk/
http://www.ideas-r-us-software.uk/
http://www.ideas-r-us.co.uk/forum/
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• A JPEG file type was not detected. Fixed. 
• Some of the preview thumbnails in the Studio Library Entry are 300 x 300 pixels, whilst others are 100 

x 100 pixels. The picture thumbnail preview box did no show the image at the correct size. Fixed. 
• Some Cloud Library Entry names in the tree-view list had a file extension. Removed the file extension 

from the Cloud Library Entry name. Fixed. 

2.5.1.3 Improved 
• Removed the comma at the end of the keywords list for Non-cloud Library Entries. 
• Added a spaced between the commas fro Cloud Library Entry keywords. 
• The time taken to un-check all the extracted library entries in the tree-view list. 

2.6 Reporting Issues (Bugs) 
Issues can be reported by going to the forum at http://www.ideas-r-us.co.uk/forum/. 

2.7 System Requirements 
• Requires Windows XP, Windows Vista, Windows 7, Windows 8.x or Windows 10. 
• At least 3MB of hard disk space 
• The application uses about 25MB of DRAM. 
• Requires the Microsoft .NET Framework 3.5 Service Pack 1 (Requires at least Service Pack 2 Win XP), 

if not already installed. The installer will detect if the framework is installed or not. 
o If you have Internet access it can be downloaded from http://www.microsoft.com/en-

gb/download/details.aspx?id=25150 (about 235MB) 
o If no Internet access, it may be on the operating systems install disk. 

 
The supplied files are: - 
  

SilhouetteStudioLibraryFileExtractor.exe 
SilhouetteStudioLibraryFileExtractorUserGuide.pdf 
eula.rtf 
unins000.dat 
unins000.exe 

 

http://www.ideas-r-us.co.uk/forum/
http://www.microsoft.com/en-gb/download/details.aspx?id=25150
http://www.microsoft.com/en-gb/download/details.aspx?id=25150
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3. The Application 
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3.1 Background Information 
The entries in the Silhouette Studio library don’t use human readable names; the filenames are converted to 
numbers. This makes it difficult to see the files. 
 
The library entries in Silhouette Studio library can store any file type supported by Silhouette Studio (e.g., 
BMP, PNG, GSD, Studio). Each entry in the library consists of a file drawing/image type, a preview thumbnail 
and some user entered information about the file. 
 
All the files downloaded from the Silhouette Design Store (http://www.silhouettedesignstore.com/) are first 
stored in the Recent Downloads folder, but they can be later moved to any user created folder. 

3.1.1 The Silhouette Studio Cloud Update 
Starting with Silhouette Studio version 3.7.026 that was released on the 26 April 2016, the Silhouette Studio 
Library Structure has been changed to allow ‘Cloud’ storage of some of the library files. All the files will be 
copied to the cloud52 folder. 

3.2 Main Features 
The application will extract the original file type, the preview thumbnail and the library file details for each 
library entry in the Silhouette Studio library.  
 
A folder/file viewer allows one or more library entries to be selected, and extracted. 
 
The extraction produces 3 types of file: - 
 

1. The original file format that was imported into the library, Bitmap/Raster or Vector file 
2. The preview thumbnail as displayed in the Silhouette Studio software, a PNG bitmap 
3. The library file details (Artist, Description, Category, Keywords), in a text file 

 
The fonts, patterns, and recycle folder are extracted. 
 
The extracted folder structure of the Silhouette Studio library is maintained. 

3.3 Running the Application 
Silhouette Studio Library Converter Free can be run with the Silhouette Studio open, but sometimes the library 
is only updated when Silhouette Studio is closed. 
 
There are three ways that the Silhouette Studio Library Converter Free application can be started: - 
 

1. Clicking on the desktop program icon (if created). 
2. From the start menu -> Programs -> Ideas R Us Software -> Silhouette Studio Library File Extractor 

Free -> Silhouette Studio Library File Extractor Free (if created). 
3. By clicking on the SilhouetteStudioLibraryFileExtractor.exe in the 

SilhouetteStudioLibraryFileExtractorFree folder (where the application was installed). 
 
While the library entries are being read in, a progress bar will be displayed (see Picture 1 Progress Bar During 
the Reading of the Library Entries). This may take some time depending on the number of library entries in the 
Silhouette Studio Library. 
 

http://www.silhouettedesignstore.com/
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The main form will appear (see Picture 2 Screen Shot of the Silhouette Studio Library File Converter Free (Non 
Cloud Version)), or if the Cloud version of the software is being used (see Picture 3 Screen Shot of the 
Silhouette Studio Library File Converter Free (Cloud Version)). 
 
The total number of Cloud or Non Cloud entries will be shown. 
 
If there is no Silhouette Studio library an error message will be displayed (see Picture 4 No Studio Library 
Folder Found or Picture 5 No Index File of Library Entries Found). 
 
Picture 1 Progress Bar During the Reading of the Library Entries 

 
 
Picture 2 Screen Shot of the Silhouette Studio Library File Converter Free (Non Cloud Version) 
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Picture 3 Screen Shot of the Silhouette Studio Library File Converter Free (Cloud Version) 

 
 
Picture 4 No Studio Library Folder Found 

 
 
Picture 5 No Index File of Library Entries Found 

 

3.3.1 Not Read in Or Missing Library Entries 
If the Silhouette Studio Library Index File has missing entries in it, or the library entry file itself may have been 
deleted or is corrupt, an error message will be displayed (see Picture 6 Not Read in or Missing Library Entries). 
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The library index may need re-indexing, especially after a library entry has been deleted from the library (it will 
be placed in the Recycle Bin). 
 
Picture 6 Not Read in or Missing Library Entries 

 
 

• To re-index the Silhouette Studio library, exit the Silhouette Studio Library File Extractor, and start 
Silhouette Studio. 

• From the menu, select Edit -> Preferences…, then click the Reindex Library… button ( see Picture 7 
Re-index Library Option in Silhouette Studio V3). 

• Start the Silhouette Studio Library File Extractor, the Library Files count and the folders should now be 
the same as in My Library (see Picture 8 My Library Showing the Folders and Totals (Non Cloud 
Version)) 

 



Silhouette Studio Library File Extractor Free V1.1.15 User Guide 
 

Page 17 

Picture 7 Re-index Library Option in Silhouette Studio V3 
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Picture 8 My Library Showing the Folders and Totals (Non Cloud Version) 

 
 
There may an old index file for the original non-cloud version, but with no Library Entries in it (see Picture 9 A 
Non Cloud Library Index file has been found). 
 
There may be other old non-cloud unused files, that will show a warning. 
 
Picture 9 A Non Cloud Library Index file has been found 

 
 

3.3.2 Other Errors 
 

• Cannot read in a cloud library index file. 
• Cannot read in the patches file. The Library Entries may not have the correct name or details. 
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• Cannot read in the renamelist file. The Library Entries may not have the correct name or details. 
• Error reading in data from the file. 
• Error reading in the file entry in the cloud index file. 
• Error reading in the entry in the cloud index file. 
• Error setting the position in the file. 
• Error unknown entry in the cloud index file. 
• The library entry ‘xxxxx’ has errors. 
• The Studio Library version is not supported. 
• This in not an Studio Library file. 
• There is no drawing/image file to extract. 
• Unknown file format. 
• Unknown library drawing file format. 
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4. Menu 
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• File Menu 
• Help Menu 

4.1 File Menu 
 

 
 
• Exit 

4.1.1 Exit 
Menu -> File -> Exit 
Alt + F4 
 
Exit or closes the application. 

4.2 Help Menu 

 
 

• User Guide 
• Installation Folder 
• Silhouette Studio Library Folder 
• Check for Updates 
• About 

4.2.1 User Guide 
Menu -> Help -> User Guide 
 
You are reading it! This will open the PDF User Guide. A PDF reader must be installed to view the User Guide; 
otherwise an error message will be displayed. 
 
It is located in the Installation Folder, or in the Documents sub-folder (see 4.2.2 Installation Folder). 

4.2.2 Installation Folder 
Menu -> Help -> Installation Folder 
 
This will open the folder where the ‘Silhouette Studio Library File Extractor’ is installed. If it cannot, an error 
message will be displayed. 
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Picture 10 Installation Folder 

 

4.2.3 Silhouette Studio Library Folder 
Menu -> Help -> Silhouette Studio Library Folder 
 
This will open the folder where the ‘Silhouette Studio Library Folder’ has been created. If it cannot, an error 
message will be displayed. 
 
Picture 11 Silhouette Studio Library Folder 

 
 

4.2.4 Check for Updates 
Menu -> Help -> Check for Updates 
Ctrl + U 
 
Checks if there is an update to the current application. 
 
The latest release/update is also available from the Ideas R Us Software website (http://www.ideas-r-us-
software.uk/), from the Downloads web page. 
 
If the version is up to date, the message box in Picture 12 The Current Version is up to Date will be displayed. 
 
If there is an update available, the message box in Picture 13 There is a New Version Available will be 
displayed. 
 

http://www.ideas-r-us-software.uk/
http://www.ideas-r-us-software.uk/
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If there is a problem with the network connection or the update server, the message box in Picture 14 Network 
Connection Problem or Picture 15 Update Server Problem will be displayed. 
 
Note: There may be a delay before a pop-up message box, or an error message appears. 
 
Picture 12 The Current Version is up to Date 

 
 
Picture 13 There is a New Version Available 

 
 
Picture 14 Network Connection Problem 

 
 
Picture 15 Update Server Problem 

 

4.2.4.1 Download the New Version 
To download the new version, click the ‘Yes’ button in Picture 13 There is a New Version Available, the ‘Save 
As’ dialogue box will appear (see Picture 16 Select the Location to Save the Set up File). Clicking the ‘No’ 
button will cancel the download. 
 
Select the folder where the download file is to be saved (the file name can be renamed if required), then click 
the ‘Save’ button. After the file has finished downloading, a message will be displayed. Click the ‘OK’ button. 
 
Note: There is a short delay while the file is downloading. 
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Picture 16 Select the Location to Save the Set up File 

 
 
Picture 17 The File has downloaded 

 

4.2.4.2 Installing the Update 
To install the update, the Silhouette Studio Library File Extractor Free application must be closed down. 
 
An installation guide is available if help if needed with the install. See the Downloads web page from the Ideas 
R Us Software website (http://www.ideas-r-us-software.uk/). 

4.2.4.3 Other Error Messages 
These are system errors. 
 

• The version information on the server is incorrect. 
• The version infomation file on the server is missing. 
• The download link on the server is missing. 
• The setup file on the server is missing. 

 
Note: Under certain conditions if the server is down or there is no network connection, these can also be 
displayed. 

http://www.ideas-r-us-software.uk/
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4.2.5 About 
Menu -> Help -> About 
F1 
 
Shows the ‘Silhouette Studio Library File Extractor Free’, which is just version information, and where to 
report issues with the application. 
 
Picture 18 The ‘About’ Form for a Free Version 
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5. Extracting the Library Files 
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5.1 Selecting the Library Entries to be extracted 
All of the Library Entries to be extracted can be selected (see Picture 19 All the Library Entries Selected), or 
just a few (see Picture 20 Some of the Library Entries Selected). 
 
To select (or un-select) a single library entry, click on the check box next to the library entry name. To select all 
the library entries in a folder, click on the check box by the folder name. The number of selected library entries 
will be shown. 
 
The ‘Expand’ button will expand all the tree nodes, whilst the ‘Collapse’ button, will collapse all the tree nodes. 
 
Picture 19 All the Library Entries Selected (Non Cloud Version) 
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Picture 20 Some of the Library Entries Selected (Non Cloud Version) 

 

5.2 Folder Mapping and Renaming 
The naming of the some of the folders is different to that in the Silhouette Studio Library, as well as the sort 
order. See Picture 21 My Library in Silhouette Studio  (Non Cloud Version) and Picture 22 The Library Entries 
Folders in Silhouette Studio Library File Extractor  (Non Cloud Version). 
 
Folders that do not contain any library entries are not shown in the Silhouette Library File Extractor, but will be 
shown in the My Library in Silhouette Studio. 
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Picture 21 My Library in Silhouette Studio  (Non Cloud Version) 

 
 
Picture 22 The Library Entries Folders in Silhouette Studio Library File Extractor  (Non Cloud Version) 

 
 
The Mapping of Silhouette Studio Library to converted/extracted folders is shown in the tables below; see 
Table 1 Mapping of Silhouette Studio Library to the Extracted Destination Folder (Non Cloud Version). 
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Table 1 Mapping of Silhouette Studio Library to the Extracted Destination Folder (Non Cloud Version) 

Studio Library Destination Folder 
My Library M:\SilhouetteLibrary 
  
Show All Designs  
My Fonts M:\SilhouetteLibrary\Non-Cloud\Fonts 
My Patterns M:\SilhouetteLibrary\Non-Cloud \Patterns 
My Library M:\SilhouetteLibrary\Non-Cloud \Library 
    Recent Downloads M:\SilhouetteLibrary\Non-Cloud \Downloads 
    My Own Designs M:\SilhouetteLibrary\Non-Cloud \My Designs 
    Test M:\SilhouetteLibrary\Non-Cloud \Test 
    Test2? M:\SilhouetteLibrary\Non-Cloud \Test2_ 
    Untitled Folder M:\SilhouetteLibrary\Non-Cloud \Library\Untitled Folder 
00000Patterns M:\SilhouetteLibrary\Non-Cloud \00000Patterns 
Recycle Bin M:\SilhouetteLibrary\Non-Cloud \Recycle Bin 
 
Note: - Test2? has been renamed to Test2_, since ‘?’ is not a valid folder name. 
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Picture 23 My Library in Silhouette Studio  (Cloud Version) 
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Picture 24 The Library Entries Folders in Silhouette Studio Library File Extractor  (Cloud Version) 

 
 
The Mapping of Silhouette Studio Library to converted/extracted folders is shown in the tables below; see 
Table 2 Mapping of Silhouette Studio Library to the Extracted Destination Folder (Cloud Version). 
 
Table 2 Mapping of Silhouette Studio Library to the Extracted Destination Folder (Cloud Version) 

Studio Library Destination Folder 
My Library M:\SilhouetteLibrary 
  
Show All Designs  
Local User  
    Fonts (Empty) 
    Library  
        ABCdef GHIjKL (Empty) 
        Abc_DefG (Empty) 
        Recent Downloads M:\SilhouetteLibrary\Local User\Library\Recent Downloads 
        Test M:\SilhouetteLibrary\Local User\ Library\Test 
        Test2? M:\SilhouetteLibrary\Local User\ Library\Test2_ 
        Untitled Folder M:\SilhouetteLibrary\Local User\ Library\Untitled Folder 
        User Designs M:\SilhouetteLibrary\Local User\ Library\User Designs 
Patterns M:\SilhouetteLibrary\Local User\Patterns 
Recycle Bin M:\SilhouetteLibrary\Local User\Recycle Bin 
myname@anyname.uk  
    Fonts M:\SilhouetteLibrary\ myname@anyname.uk \Fonts 
    Library  
        Project Designs (Empty) 
        Recent Downloads M:\SilhouetteLibrary\ myname@anyname.uk \Library\Recent Downloads 
        User Designs (Empty) 
        Patterns M:\SilhouetteLibrary\ myname@anyname.uk \Library\Patterns 
        Recycle Bin (Empty) 
 
Note: - Test2? has been renamed to Test2_, since ‘?’ is not a valid folder name. 
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5.3 Library Entry details 
These are the library entry details that appear in the Silhouette Studio Library, when the properties of a library 
entry are shown. 
 
They consist of: - 
 

• Library entry name and file extension/type 
• Thumbnail (this may not be what the drawing actually looks like) 
• Description 
• Artist name 
• Category type 
• Date and time the library entry was added to the library (not the drawing itself) 
• Keywords 

 
The Library Entry Details will be saved in a text file, e.g. 3d cactus.txt, and the thumbnail as a PNG file. 
 
Picture 25 Library Entry Details for a Selected Entry 

 

5.4 Set the Destination Folder for the Extracted Files 
Click on the ‘Destination’ folder button, and select the drive and folder (or create a new folder) where the 
extracted library is to be saved. 
 
Picture 26 The Destination Folder Group Box 
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Picture 27 Selecting the Destination Folder 

 
 
Picture 28 The Destination Folder has been selected 

 
 
The destination path and the free disk space on that drive will be shown for the selected drive, the number of 
library files to be extracted, the required disk space (see Picture 32 Finished Extracting the Entries), or an error 
message if there is not enough space to extract the files (see Picture 29 Not Enough Disk Space). 
 
Picture 29 Not Enough Disk Space 

 

5.5 Extracting the Files 
Click on the ‘Extract’ button to begin (it will be disabled if there are no library files, or there is no free disk 
space). If there are files on the destination drive/folder, a message box will appear. Click on ‘OK’ to continue 
and to overwrite them, or cancel to stop extracting. 
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Picture 30 Files Exist on Destination Drive/Folder 

 
 
A progress bar will appear when the library entries are being extracted. 
 
Picture 31 Progress Bar 

 
 
When all the library entries have been extracted, a message box will appear. Click on OK to finish. Any errors 
will be displayed in the errors and warning messages box (see Picture 36 The Errors and Warning Messages). 
 
Picture 32 Finished Extracting the Entries 

 
 
The extracted library entries will have the check mark removed from the library entry, and the entry name will 
be green (this is only temporary and will be black the next time the application is run). 
 



Silhouette Studio Library File Extractor Free V1.1.15 User Guide 
 

Page 36 

Picture 33 The Extracted Library Entries Un-checked and Entry Name in Green (Non Cloud Version) 

 
 

5.6 Extracted Files Folder 
This is what has been extracted from the library, GSD file, PNG thumbnail (post fixed with _tn), Studio files 
and the file details in text files. 
 
Picture 34 The Extracted Files in the Destination Folder 

 
 
The Silhouette Studio Library can contain entries that have the same name. The extracted files will be re-named 
by post fixing the file name with ‘(2)’. If there are three library entries called Flower, there will be re-named to: 
- 
 

Flower.studio 
Flower.txt 
Flower_tn.png 
Flower (2).studio 
Flower (2).txt 
Flower_tn (2).png 
Flower (3).studio 
Flower (3).txt 
Flower_tn (3).png 
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5.7 Other Errors 
 

• Cannot check the destination drive for existing files. 
• Cannot delete the library entries errors and warnings log file. 
• Cannot delete the library entries processed log file. 
• Cannot write to the library entries errors and warnings log file. 
• Cannot write to the library entries processed log file. 
• Error creating the destination folder. 
• The file cannot be written to disk. 
• The library details file cannot be written to disk. 
• The preview bitmap file cannot be written to disk. 

5.8 Displaying the Log Messages 
The errors and warnings or library entries processed messages can be shown separately, by selecting the 
appropriate radio button in the ‘Show Messages’ group (see Picture 35 Selecting the Error and Warning or 
Library Entries Processed). 
 
An error or warning message doesn’t usually stop the library entry from being extracted, but an error message 
would mean that the extraction was not completed for the library entry, and there may be missing files. 
 
Picture 35 Selecting the Error and Warning or Library Entries Processed 

 
 
Two log files containing all the error and warning or library entries processed messages during extracting are 
saved in the destination folder as ‘LibraryEntriesWithErrorsWarningsLog.txt’ and 
‘LibraryEntriesExtractedLog.txt’. 
 
Picture 36 The Errors and Warning Messages 

 
 
There may be some files with the extension ‘.unknown’. These could not be auto detected, and may be of the 
supported library import types (the designer edition supports more file types). 
 
Some of the error/warning messages that may appear after the library entries have been extracted. 
 
Warning: Invalid characters in the filename have been replaced. 
  Non-Cloud\Library\Downloads\christmas/holiday tags to Non-
Cloud\Library\Downloads\christmas_holiday tags 
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Warning: Invalid characters in the filename have been replaced. 
  Non-Cloud\Library\My Designs\Coloured Squares - !"£$%^&*()_+ to Non-Cloud\Library\My 
Designs\Coloured Squares - !_£$%^&_()_+ 
Warning: Invalid characters in the filename have been replaced. 
  Non-Cloud\Library\My Designs\Example G3 - "&*<>?/\ to Non-Cloud\Library\My 
Designs\Example G3 - _&______ 
Warning: Invalid characters in the filename have been replaced. 
  Non-Cloud\Library\Test\File with Illegal Char '?' - Circle 40mm - Welded to Square 60mm 
to Non-Cloud\Library\Test\File with Illegal Char '_' - Circle 40mm - Welded to Square 
60mm 
Warning: Invalid characters in the folder name have been replaced. 
  M:\SilhouetteLibrary\Non-Cloud\Library\Test2? to M:\SilhouetteLibrary\Non-
Cloud\Library\Test2_ 
 

 
Picture 37 The Library Entries Processed 

 
 
This shows some of the Library Entries from the log file. It gives the library entries extracted and not extracted, 
as well as the total of each. 
 
Note: There may be differences between the Library file count on the form, the count during extracting and the 
final total entries processed. 
 
Library Entries Extracted Okay                      371 
Library Entries Extracted with Errors and Warnings  5 
Library Entries not Extracted                       0 
--------------------------------------------------------- 
Total                                               376 
 
Library Entries Okay 
-------------------- 
Non-Cloud\00000Patterns\c00481_209067 
Non-Cloud\00000Patterns\d53699 
Non-Cloud\00000Patterns\d64528 
 
. 
. 
. 
 
Library Entries with Errors and Warnings 
---------------------------------------- 
Non-Cloud\Library\Downloads\christmas/holiday tags 
Non-Cloud\Library\My Designs\Coloured Squares - !"£$%^&*()_+ 
Non-Cloud\Library\My Designs\Example G3 - "&*<>?/\ 
Non-Cloud\Library\Test\File with Illegal Char '?' - Circle 40mm - Welded to Square 60mm 
Non-Cloud\Library\Test2?\s.studio 003 
 
Library Entries not Extracted 



Silhouette Studio Library File Extractor Free V1.1.15 User Guide 
 

Page 39 

----------------------------- 
 

 



Silhouette Studio Library File Extractor Free V1.1.15 User Guide 
 

Page 40 

 

6. Acknowledgments 



Silhouette Studio Library File Extractor Free V1.1.15 User Guide 
 

Page 41 

I would like to thank the following for their assistance whilst developing this application. 

6.1 Demo/Free Release Testers 
Members of the Thyme Machines forum, (http://www.thymemachines.com): - 
 

• Helen Rich (crafty49) 
• Gary Hawkins (Dragon Lord) 
• (Hazel P) 
• Mary Pelling (Mary P) 
• Lucy Gregg (Loopylass) 
• And Others 

 
 
Julie Flanagan, who has over 14,000 files in her Silhouette Studio library. 
 

http://www.thymemachines.com/


Silhouette Studio Library File Extractor Free V1.1.15 User Guide 
 

Page 42 
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7.1 Un-Installing 
The Silhouette Studio Library File Extractor Free application can be un-installed from the Start Menu (see 
Picture 38 Un-installing from the Start Menu). 
 
If there isn’t a Silhouette Studio Library File Extractor Free Start Menu folder, the program can be un-installed 
from the Windows ‘Add/Remove Programs’ control panel. 
 
It can also be un-installed from double clicking on the unins000.exe in the Silhouette Studio Library File 
Extractor Free installed folder. This is usually in the 
IdeasRUsSoftware\SilhouetteStudioLibraryFileExtractorFree folder. 
 
Any extracted files will not be deleted. 
 
Picture 38 Un-installing from the Start Menu 

 
 
A confirmation pop-up message box will be displayed, click ‘Yes’ to install, and ‘No’ to cancel uninstall. 
 
Picture 39 Confirm Uninstall 

 
 
The Silhouette Studio Library Converter Free application has been successfully removed. 
 
Picture 40 Successfully Uninstalled 
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7.2 Keyboard Shortcuts 
Exit Program  Alt + F4 
Check for Updates Ctrl + U 
About   F1 

7.3 Previous Release Notes 
7.3.1 Changes Made in Version 1.1.00 
7.3.1.1 New Features 

• Added a progress bar when reading in the Library Entries. 
• A tree view folder and file type interface to support both Cloud and Non Cloud libraries, instead of the 

single/all library folder selector. 
• Added some more support for Cloud libraries (reading some of the library entry details), but the entries 

will not be extracted. 

7.3.1.2 Issues Fixed 
• Large libraries take a long time to load. Fixed. 
• Some Library Entry details that had been changed where not correct. Fixed. 
• HTML encoded characters in the library entry details description such as '&Amp', weren’t decoded to 

‘&’. Fixed. 
• When both the scroll bars appear, the right scroll bar obscures the longest line of text. Added a line of '*' 

that are longer by 5 than the longest line. Fixed. 
• Replacing illegal filename/path name characters showed the replaced chars and not the actual 

characters. Fixed. 

7.3.1.3 Improved 
Some of the error/warning messages have been changed. 

7.3.2 Changes Made in Version 1.0.35 
7.3.2.1 New Features 
Versions of Silhouette Studio 3.7.026 and later have had the folder location changed to cloud52, and the library 
file structure changed. This has not yet been fully implemented, but any files in the ‘Cloud’ folder will be 
displayed, but cannot be extracted. 

7.3.2.2 Issues Fixed 
• When the number of Library Entries was large, the main form didn’t appear straight away, given the 

impression that the program wasn’t working. It now appears straight away. Fixed. 
• Entries in the errors/warnings list box could be selected, but not copied. They can no longer be 

selected/highlighted. Fixed. 

7.3.3 Changes Made in Version 1.0.31 
7.3.3.1 Issues Fixed 
There was an error reading in the index file on Windows 7 64-bit. Fixed. 
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7.3.4 Changes Made in Version 1.0.30 
7.3.4.1 Issues Fixed 

• The method used to read the library files was wrong. This resulted in old library files being extracted 
when they had been moved to another folder. The index file is now used instead, which gives an 
accurate count of the library entries. Fixed 

• When a Silhouette Studio Library system file didn’t have any entries, an error occurred. Fixed. 

7.3.4.2 Improvements Made 
• The required disk space label has been change from whole mega bytes to the nearest 1/100 of a mega 

byte. 
• On the progress form, the total number of library entries is shown, e.g. 1 of 250. 

7.3.5 Changes Made in Version 1.0.20 
7.3.5.1 New Features 

• Check for existing files on the destination drive, and to display a warning pop-up if any exist. 
• A progress bar when files are being extracted. 
• The design number is added the extracted library details text file. It is the same number that is used by 

the online Silhouette Studio store. 
• The single log file is replaced with two log files. One that lists the library entries extracted, and one that 

lists the errors and warnings for the library entries. The form’s radio buttons text has been renamed. 

7.3.5.2 Issues Fixed 
• The extracted GST files were renamed to GSD files, now they are not renamed. Fixed. 
• Some of the library entries didn't have any drawing/image file to extract. Fixed. 
• Some of the library entries don't have a bitmap preview. Fixed. 
• Library entries having the same name were overwritten. Now they are renamed. Fixed. 
• Library folder names may contain illegal characters when converted to system folder names, causing an 

error. Fixed. 
• An 'Unknown' category code in the library detail may have caused an error. Fixed. 
• Some library entries don't have all the library details (missing artist name, etc). A missing library entry 

name will use the design number instead. Fixed. 
• When the library entry details are changed in Silhouette Studio, two external files are used to store these 

changes (changes to the library entry name are also stored in them). These changes are now read in and 
applied to the extracted library entry details. Fixed. 

7.3.5.3 Improvements Made 
• Prefixed the invalid characters warning messages with 'Warning'. 
• Changed the text in the messages list box to a fixed space font. 

7.3.6 Changes Made in Version 1.0.00 
The version change jump is to coincide with the Free release version. 

7.3.6.1 New Features 
• Added a menu item for User Guide in the Help menu. 
• Added a menu item for the Installation Folder in the Help menu. 
• Added a ‘Product Brand’ icon to the .exe file and to the main form. 
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7.3.6.2 Updated 
• Changed a link on the Help -> About Form to ‘ideas-r-us-software.co.uk’, and changed the name from 

‘Ideas R Us’ to ‘Ideas R Us Software’ 
• Renamed from the 'Convert' button to 'Extract'. 
• Renamed various occurrences of the text 'Silhouette Studio Library Converter' to 'Silhouette Studio 

Library File Extractor'. 

7.3.6.3 Improvements Made 
• Disabled the form’s maximise control button, since no form controls are re-sizable. 
• The installer will open the DOT NET framework website if 3.5 isn't found. 
• Checked the 'add desktop and quick start icon' check boxes in the installer. 
• The group 'Show Messages' will be enabled if there are Error or Warning messages. 

7.3.7 Changes Made in Version 0.5.06 
7.3.7.1 New Features 

• Added a Check for Updates feature to the Help menu. 
• Added a File Menu and an exit application menu item. 
• Added keyboard short cuts to all the menu items 

7.3.7.2 Improvements Made 
In the Studio Library Folder drop down box, replaced the ‘blank’ entry for all the folders with <All Folders>. 

7.3.8 Known Issues 
• This has not been tested with any Silhouette Studio Versions before 1.9. 
• The library details file may not contain the updated info; since the ‘patches’ file isn’t read in. 
• The destination folder can be the same as the source folder, which shouldn’t be allowed. 
• Any existing files in the destination folder will be overwritten without warning. 
• An unknown file format will display a warning message. 
• The Silhouette library folder and file names can have characters that contain invalid characters when 

written to disk. They are replaced with an underscore ‘_’, so ‘MyFile:’ will become ‘MyFile_’. 

7.3.9 Changes Made in Version 0.5.05 
7.3.9.1 New Features 

• It is now possible to convert/extract a library sub-folder, instead of just all the library. 

7.3.10 Changes Made in Version 0.5.04 
7.3.10.1 Issues Fixed 

• Some files were being incorrectly saved as GSD. Added auto detect of file types to fix this. 
• Any unknown file type will have the file extension ‘.unknown’ added, and add a warning message. 
• GST (GSD template files) files are now renamed to GSD, the warning message about this has been 

removed. 
• It now correctly detects and replaces invalid characters in the folder names. 
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